Next: , Previous: , Up: Top   [Contents]


Menus

The GUI menu system is used to perform configuration, emulation launching and other tasks. Configuration changes are saved to the database file kat5200.db3.

File

The File menu contains the following:

Load Rom

This menu item brings up a file browser allowing the user to navigate to a rom image to load. The selected image is then lauched, i.e. the system is cold started, rather than just being attached to the emulated device.

Save State

This menu item brings up a profile browser, where the user may save the current emulated state to an existing profile or new one. The state is saved to the database under a unique profile name.

Load State

This menu item brings up a profile browser, allowing the user to load a saved state. The emulation is then immediately started.

Quick Save State

This menu item allows the user to save the current emulated state to one of nine slots

Quick Load State

This menu item allows the user to load one of nine saved states. The emulation is then immediately started.

Launcher

This menu item brings up the launcher window, allowing the user to launch or configure rom images. Described in detail below.

Back to Game

This menu item enters back into the emulation.

Exit

This menu item exits the emulator.

Launcher

The Launcher is a window containing a list of known images for the user to configure and load (file name of the image must be set to load). The user selects an image by clicking it in the list and launches it by double-clicking or selecting and pressing ENTER. The user may search for images using the scrollbar or by typing the characters in the image name to navigate down the list. For each image, the user may configure things such as input profile, image file, and machine settings.

The Laucher Media Image menu contains the following options:

Launch

This launches the currently the selected image, i.e. the image is attached and a cold start is performed.

Launch - No Reset

This loads and attaches the image to the emulated device. The machine is not reset.

Attach

This is the same as Launch - No Reset, except the user may choose which emulated device to attach the image to.

Delete

This menu item deletes the currently selected entry from the list permanently.

Add to Favorites / Remove from Favorites

This menu item adds the currently selected image to the favorites list. This list can be shown from the View menu. If the image is in the favorites list, the user has the option to remove it from favorites.

The View menu contains the following options:

All - Shows all images in the database
Available - Shows all images found on the user's system.
Unavailable - Shows all images not found on the user's system.
Favorites - Shows images the user has added to the favorites list.

The Misc menu contains the following options:

Add Media Image

This menu item brings up a file browser, allowing the user to navigate to an image to add to the database. The image name will be based on the filename.

Scan for Files

This menu item brings up a file browser, allowing the user to navigate to the desired directory to scan. Files in that directory and (optionally) in any sub-directories will be scanned for matches in the image database. Any images found will have their File attribute set and may be loaded from the Launcher.

Options

This menu item brings up a window allow the user to set launcher window options. The user may select to view rom images for the selected machine or to view all rom images. Also the user may select to seperate the list into tabbed views. This can be done by TOSEC dat file type, media type (cart, floppy, cassette, executable), or alphanumerically (no more than 1000 images per tab).

At the bottom of the Launcher window is a tabbed view with rom image settings for the selected image.

Image

On this tab, the user may set the title of the image, and machine type.

File

On this tab, the user may set the file containing the image, and shows various rom image statistics.

Profiles

On this tab, the user may choose a specific input, video, or sound profile to use with the image, or to choose to use the defaults for each.

Settings

For images belonging to the 8-bit machine, the user may set whether to load BASIC with the image, whether to use the SIO patch to load the image, and amount of RAM to use. For both machine types, mapping the image to a specific type can be done. This is especially useful if it seems the emulator is loading the image incorrectly when set to auto, the user may attempt to fix this.

Machine

The Machine menu contains the following (when launching rom images, the settings for the particular image will override these):

System

The menu item allows the user may choose between Atari 5200, Atari 800, Atari XL/XE.

RAM

This menu item allows the user to choose the amount of RAM to emulate.

Video

This menu item allows the user to choose between NTSC and PAL video systems.

Throttle

This menu item brings up a window to set the speed of the emulation. 100% represents normal speed. Checking ’Run as fast as possible’ will cause the emulation to run as fast as the PC will allow.

BIOS Files

This menu item brings up a window allowing the user to set the BIOS and BASIC files used with each of the machines. The user may use the Browse buttons to bring up a file browser to select the file. These fields are also populated automatically during a scan if the appropiate files are found.

Media

This menu item brings up a window showing using currently attached rom images to the each of the emulated devices. The user may also attach rom images by using the Browse buttons to bring up a file browser to select the file.

SIO Patch

This check menu item allows the user to select to use the SIO patch or not. The SIO Patch allows for fast loading of floppy and cassette images, but may not be compatible with all rom images.

BASIC Enabled

This check menu item allows the user to select to boot the system with BASIC enabled or not. Some rom images require BASIC to work, but most won’t work with it enabled. Therefore, it’s generally best to leave this off and set BASIC to on for the individual images that need it in the Launcher.

Reset

This menu item allows the user to Reset the emulated machine. This can be a warm (CPU reset) or Cold (Power cycle).

View

The View menu contains the following:

Screen Size

This menu item allows the user to set the zoom. Also available in the Video configuration.

Fullscreen

This check menu item allows the user to toggle between fullscreen and windowed mode. Takes effect when exiting the GUI back to the emulation.

Options

The Options menu contains the following:

Video

This menu item brings up the Video configuration window with the following options:

Profile

This section allows the user to choose which video profile to setup. The user may also save the current configuration to a new profile and may set which profile is used by default.

NTSC Filter

This sections allows the user to enable, disable, and configure NTSC television effects. Presets for RF, Composite, S-Video, and RGB are provided.

Fullscreen

This check box allows the user to toggle between fullscreen and windowed mode.

Widescreen

This check box allows the user to choose to display extra pixels on the left and right of the screen.

Fixed Window

If not checked, the window will be re-sizable. If checked it will be a fixed resolution. Useful with tiling window managers to have the window run in tiled or floating mode.

Window Resolution

Size of the window, updated automatically when re-sized

Screen Image

Also included is a screen shot of the current emulation. The user may use the mouse to drag to different parts of the screen. This can be useful to see the effects of any palette changes or NSTC filter adjustments.

Sound

This menu item brings up the Sound configuration window with the following options:

Profile

This section allows the user to choose which sound profile to setup. The user may also save the current configuration to a new profile and may set which profile is used by default.

Enable Sound

This check box allows the user to enable / disable all sound.

Frequency

This drop down allows the user to set the sampling frequency. Generally, set this to the highest value that does not affect performance. The default should work well for most systems.

Samples

This drop down allows the user to set the sound buffer size in samples. The default should work for most systems, but the user may tweak to improve performance.

Input

This menu item brings up the Input configuration window with the following options (each player and the keyboard are tabbed and set seperately):

Profile

This section allows the user to choose which input profile to setup. The user may also save the current configuration to a new profile and may set which profile is used by default.

Controller / Paddles / Joystick / Keypad

These sections contain buttons for each controller function. Push the button to see the current settings in the PC Input section.

PC Input

This section provides the user with a way to setup the currently selected controller function. Generally it is best to use Auto-Detect and then perform the desired action to setup.

Device

This is Keyboard, Joystick, or Mouse

Device Num

This is the index of the device as detected by SDL. Only applies to joysticks and when there are multiple joysticks connected to the system.

Part Type

For a joystick, this can be an Axis, Button, D-Pad, or Trackball. For a Mouse this can be an Axis or a Button. For the keyboard, this can only be a Key.

Part Num

For a joystick or mouse, this is the index of the part as detected by SDL. For the keyboard, this is the key.

Direction

For a D-Pad, this can be Left, Right, Up, or Down. For an axis it can be + or -. For a key or button, this can be Pressed or Released.

A5200 / A800 Controller

This sections allows the user to set the controller type for the selected player.

PC Control Settings

These settings apply to emulation of the 5200 Joystick and 8-bit Paddle controllers only.

Sensitivity

This slider allows the user to change the range of the atari pot values. For some 5200 games like Gorf, Missle Command, and Super Breakout, setting this to somewhere between 50 and 75 percent when using an analog stick can make the game more playable. This can also be used with Simulate Analog for "Pengo" type games.

Deadzone

This slider allows the user to set the deadzone of the user’s analog controller. A lower value will give the user a wider analog range but could cause jitter, while a higher value will reduce jitter, but will also reduce range. This is 20% by default. The preference would be to set this to the lowest value that has no jitter.

Simulate Analog

When using the keyboard, D-Pad, or digital stick as a controller, checking this can make games where the position of the analog stick is important (as opposed to direction) more playable. This is similiar to Pengo mode in VSS and Jum52. Useful for 5200 games like Gorf, Missle Command, and Super Breakout.

Mouse Speed

Mouse speed can be set to a value 1-5. For using the mouse as the 5200 trackball, a setting of 3 is good. For using the mouse as the 8-bit paddles a setting of 1 is good.

User Interface

This menu item brings up the User Interface configuration window with the following options:

Profile

This section allows the user to choose which user interface profile to setup. The user may also save the current configuration to a new profile and may set which profile is used by default.

Font

This is the font file used. It must comply with Guichan standards for Image Font. Use the browse button to set the file.

Start Options

This section provides the user with the ability to control what happens at program start. By default the program will enter the emulation with the last rom image run. The user may choose to have the program start with the GUI as well as having the GUI always start up with the Launcher window.

Controls

These sections contains buttons for each user function. Push the button to see the current settings in the PC Input section.

PC Input

This section provides the user with a way to setup the currently selected user function. Generally it is best to use Auto-Detect and then perform the desired action to setup.

Device

This is Keyboard, Joystick, or Mouse

Device Num

For a key, this can be can be modifier such as ALT, SHIFT, or CTRL. Otherwise, this is the index of the device as detected by SDL. Only applies to joysticks and when there are multiple joysticks connected to the system.

Part Type

For a joystick, this can be an Axis, Button, D-Pad, or Trackball. For a Mouse this can be an Axis or a Button. For the keyboard, this can only be a Key.

Part Num

For a joystick or mouse, this is the index of the part as detected by SDL. For the keyboard, this is the key.

Direction

For a D-Pad, this can be Left, Right, Up, or Down. For an axis it can be + or -. For a key or button, this can be Pressed or Released.

Misc

This menu contains the following functions:

Palette

This menu item allows the user to perform the following:

Import

This menu item brings up a window allowing the user to browse to an Atari800 palette file to import into kat5200. The user must provide a profile name for the new palette.

Export

This menu item brings up a window allowing the user to choose a Palette to export. Once the Export button is pressed a file browser is brought up allowing the user to save to an Atari800 palette file.

Edit

This menu item brings up a window allowing the user to select and edit palettes. To edit enter in the index of the color to edit and press enter. Then change or view the color. Colors are in hexidecimal and are RRGGBB values.

Create Media

This menu item brings up a window allowing the user to create either a floppy or a cassette image for use with the 8-bit machines.

Disk

To create a floppy disk image, the user should setup the sector size, boot type, and number for sectors. Use the Create button to choose a file name and create the image.

Cassette

To create a cassette image, the user should type in a description (optional) and use the create button.

Wizard

This menu item bring up the Configuration Wizard, allowing the user to setup several items at once.

Video

The user may set the video system (PAL or NTSC) and fullscreen preferences.

Rom Image Directories

Scanning for rom images allows them to be loaded from the launcher. The user may choose to scan for 8-bit, 5200, and BIOS images. The "best fit" BIOS images will be selected for each machine type. These may be edited from the Machine->BIOS Files menu item.

Primary Input Device

This allows the user to setup the primary input device. This can either be a joystick or keyboard (mouse is not selectable here). Generally, the user should use the Auto-Detect button to automatically detect the correct control device. The Wizard will create a new input profile and set it as the default. The user may edit it in the Options->Input menu item.

View Log

This menu item brings up the contents of the log file kat5200.log. This can useful for viewing details of any errors that have occured. The file is located in the user’s application data directory in windows or in the .kat5200 directory in the user’s home directory for *nix systems.


Next: , Previous: , Up: Top   [Contents]